Package Synchronisation Time Increased
Incident Report for Cloudsmith
Resolved
Package synchronisation is now back to normal - Thank you for your patience!
Posted about 1 year ago. Jun 22, 2018 - 07:31 UTC
Monitoring
The fix has been deployed and we're going to continue monitoring performance for the next 12 hours - Package synchronisation times should be immediately better, but please let us know if that isn't the case. We're really sorry if the increased synchronised times affected you or your customers!
Posted about 1 year ago. Jun 21, 2018 - 22:02 UTC
Update
We've got the fix ready, and we're just going through additional tests before deployment. The root cause was due to a backlog in backend processing, and the fixes are primarily performance enhancements to prevent it from happening again in the future. The release will require a small amount of downtime as it requires a data migration.
Posted about 1 year ago. Jun 21, 2018 - 19:17 UTC
Identified
We have identified the source for increased package synchronisation times and we're now working on a fix.
Posted about 1 year ago. Jun 21, 2018 - 08:09 UTC
Investigating
We're currently investigating an increase in package synchronisation time. Packages will still synchronise, but will be slower than usual to do so.
Posted about 1 year ago. Jun 20, 2018 - 19:19 UTC
This incident affected: Backend Processing.