RedHat Package Checksums Failures
Incident Report for Cloudsmith
Resolved
The issue has now been resolved, and any/all affected checksums for RedHat packages have been automatically recalculated. If you encounter any further issues, please try clearing any local caches first (e.g. for yum, using "yum clean all").
Posted Apr 29, 2023 - 09:18 UTC
Monitoring
We have identified and are currently verifying a fix for an issue raised by a subset of customers distributing RedHat packages

The symptoms are, when a package has been uploaded and get signed by Cloudsmith, the checksum for the package isn't fully updated post-signature, and when clients attempt to retrieve the package with checksum validation, it fails to validate with the following:

"Downloading successful, but checksum doesn't match. Calculated: Expected "

A fix has been implemented to resolve the issue, but as it only affects a subset of customers, we're still in the process of verifying this has been fully fixed. A workaround mitigation is that a resync of the package will fix the issue. Once we fully validate the fix, we'll determine if we can backfill a fix for all affected packages.
Posted Apr 28, 2023 - 11:03 UTC