Monitoring on-going performance in EU-West
Incident Report for Cloudsmith
Resolved
Our performance returned to normal after we increased capacity in the impacted region. We believe the issue has been fixed.
Posted Feb 14, 2024 - 07:55 UTC
Update
We are continuing to monitor for any further issues.
Posted Feb 13, 2024 - 16:51 UTC
Monitoring
We have increased our database capacity in the impacted region. We are monitoring the traffic to this region and believe this increased capacity is sufficient to avoid degraded UI and API performance. We will continue to monitor UI and API performance to determine whether this is sufficient to consider this issue resolved. Further, we have identified some problematic queries that are the likely root cause of this issue that we will address with code-fixes.
Posted Feb 13, 2024 - 16:09 UTC
Update
We have scaled up capacity in the impacted region. This should mitigate most of the impact users are experiencing. We continue to investigate the root cause.
Posted Feb 13, 2024 - 15:39 UTC
Investigating
We are currently investigating degraded read performance in our EU-West region. We have noticed heavy read activity on our database. Our web-ui and api responses may be slow during this incident. We are working to establish a root-cause and taking actions to relieve the incident. You may notice degraded response at this time.
Posted Feb 13, 2024 - 15:11 UTC
This incident affected: Frontend REST API, Frontend Website, and Backend Databases.