API Endpoint Resolution Failure
Incident Report for Cloudsmith
Resolved
The API and downloads issue is now confirmed as resolved - The fix released earlier was successful in restoring functionality. Although rare, we feel terrible when an event like this occurs and we're really sorry that it impacted our users. An issue with the latest major release happened approximately an hour after deployment to production that took our API offline, and had a secondary effect of stopping downloads from working.
Posted Jun 25, 2018 - 22:33 UTC
Monitoring
We've released the fix. API endpoint now accessible; downloads and CLI interactions working again. Sorry for the disruption.
Posted Jun 25, 2018 - 16:25 UTC
Identified
We have identified the issue within the host resolution lookup and are implementing a fix.
Posted Jun 25, 2018 - 15:26 UTC
Investigating
We're currently investigating issues with the API endpoint. Website functions (including upload and synchronisation) currently unaffected but downloads are currently unavailable.
Posted Jun 25, 2018 - 15:02 UTC
This incident affected: Frontend REST API, Frontend Website, and Package Downloads (CDN).