Elevated API Errors
Incident Report for Cloudsmith
Resolved
Apologies for any inconvenience caused by this incident, it has now been resolved. We will follow up with additional information shortly.
Posted Dec 08, 2021 - 17:24 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 07, 2021 - 18:15 UTC
Identified
The issue has been identified, and several fixes have been rolled out, with more in flight. All service has been restored (including bandwidth accounting) - however, performance may remain degraded intermittently.
Posted Dec 07, 2021 - 17:43 UTC
Update
We are continuing to investigate this issue and are applying changes in an attempt resolve it. Package uploads and downloads remain unaffected.
Posted Dec 07, 2021 - 16:55 UTC
Update
We are continuing to investigate this issue. Package uploads and downloads are currently unaffected.
Posted Dec 07, 2021 - 16:13 UTC
Update
We are continuing to investigate this issue. Package uploads and downloads are currently unaffected.
Posted Dec 07, 2021 - 15:56 UTC
Update
We are continuing to investigate this issue. Package uploads and downloads are currently unaffected.
Posted Dec 07, 2021 - 15:38 UTC
Update
We are continuing to investigate the issue. Package fetches and page fetches are now stable. Some backend tasks such as upstream caching and bandwidth accounting are currently delayed.
Posted Dec 07, 2021 - 15:23 UTC
Investigating
We're currently investigating elevated errors for requests originating through United States regional infrastructure.
Posted Dec 07, 2021 - 15:00 UTC
This incident affected: Frontend Website, Frontend REST API, Backend Databases, Backend Processing, and Package Downloads (CDN).