Data Processing Delays - Reporting Tools Affected

Incident Report for Cloudsmith

Resolved

Between 17:20 UTC and 22:30 UTC customers may have experienced issues with late arriving download webhooks, client log exports, caching of upstream packages, and lagging usage reporting in the UI and API. Systems are now operating as normal and we will continue to monitor.
Posted Mar 10, 2025 - 22:30 UTC

Monitoring

We have identified an issue causing a delay in log processing. We have applied a fix and our system is now processing a backlog of logs. During this time, you may experience delays in arrival of download webhooks, exports of client logs, and caching of upstream packages. Usage reporting via the UI and API may continue to be delayed until data processing is fully caught up. We will continue to provide further updates.
Posted Mar 10, 2025 - 18:37 UTC